【備忘録】 SSH 公開鍵認証 CentOS
SSH 公開鍵認証によるログインでとてもハマったのでメモ
ssh-keygen -t rsa でサーバ側で鍵を作ってクライアントに送り /etc/ssh/ssh-config を設定。クライアントから接続するが公開鍵が動作せずパスワードを求められる。ログはこんな感じ。
debug1: Trying private key: /Users/xxxxx/.ssh/id_rsa
debug1: read PEM private key done: type RSA
debug1: Authentications that can continue: publickey,gssapi-keyex,gssapi-with-mic,password
debug1: Next authentication method: password
原因は単純でした。
サーバ側の ~/.ssh/ ディレクトリのパーミションが 775だった。
755にしたところ解決。
| 固定リンク
「パソコン・インターネット」カテゴリの記事
- TypeScriptあるいはES6(2016.07.03)
- 【備忘録】 Cordova でXcodeにエラーが出る(2016.05.20)
- キーボード交換(2016.04.23)
- 蕎麦道なび、Windows10 PCでも使えますよ(2016.02.22)
- AngularJSについて(2016.02.21)
この記事へのコメントは終了しました。







コメント